Treasury Systems partial integration outage (some customers)

Incident Report for Treasury Systems

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 16:42 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 16, 2025 - 11:22 CEST

Investigating

We are currently having problems with some integrations to the system, e.g Bankaccount Statements. We are investigating the issue. Keep checking this space for updates or subscribe above.

Regards
TS Support Team
Posted Apr 16, 2025 - 09:21 CEST
This incident affected: Treasury Systems (Application, Nomentia Bank Statements).