Treasury Systems delayed integrations (some customers)

Incident Report for Treasury Systems

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 10:29 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2026 - 09:15 CET

Investigating

We are currently having a delay in integrations for customer, this affects customers that are in the implementation phase. We are investigating the issue but all integrations will be processed but might have some delay. Keep checking this space for updates or subscribe above.

Regards
TS Support Team
Posted Mar 04, 2026 - 09:02 CET
This incident affected: Treasury Systems (Application).